# Upgrade Guide v2.0

This document provides guidelines for node operators upgrading from Regen Ledger v1.0 to v2.0. For a general overview of the upgrade process, please refer to Upgrade Overview.

Update: A patch release (v2.1.0) was released soon-after the v2.0 upgrade. This document has been updated to use the v2.1.0 as the upgrade binary rather than v2.0.0.

# Upgrade Info

# Regen Ledger v2.0

# Regen Mainnet

  • Upgrade Height: 3003343

# Redwood Testnet

  • Upgrade Height: 548703

# Upgrade Guidelines

# Update Go

Go 1.17 or later is required.

For available downloads, see Go Downloads (opens new window).

# Option 1: Using Cosmovisor

Cosmovisor v1.0 or later is required.

The following instructions assume the cosmovisor binary is already installed and cosmovisor is set up as a systemd service. If this is not the case, please refer to Using Cosmovisor for instructions on how to install and set up cosmovisor.

Auto-Download Not Supported

The auto-download option is not supported in Cosmovisor v1.0 or later when upgrading from Regen Ledger v1.0 (which uses Cosmos SDK v0.42). Enabling the auto-download option will result in an error and a failed restart at the time of the upgrade.

Build the upgrade binary (v2.1.0) from source:

cd regen-ledger
git fetch --all
git checkout v2.1.0
make build

Ensure the regen binary has been built:

./build/regen version

You should see the following:

v3.0.0

Create a v2.0.0-upgrade directory and copy the upgrade binary (v2.1.0) to the directory:

mkdir -p $HOME/.regen/cosmovisor/upgrades/v2.0-upgrade/bin
cp ./build/regen $HOME/.regen/cosmovisor/upgrades/v2.0-upgrade/bin

At the proposed block height, cosmovisor will automatically stop the current binary (v1.0.0), set the upgrade binary as the current binary (v2.1.0), and then (depending on the cosmovisor settings) perform a backup and restart the node.

# Option 2: Without Cosmovisor

Using cosmovisor to perform the upgrade is not required. Node operators also have the option to manually update the regen binary at the time of the upgrade.

When the chain halts at the proposed upgrade height, stop the current process running regen.

Build the upgrade binary (v2.1.0) from source:

cd regen-ledger
git fetch --all
git checkout v2.1.0
make install

Ensure the regen binary has been updated:

regen version

You should see the following:

v2.1.0

Restart the process running regen.